Page 1 of 1

Launcher not launching - tried everything, out of ideas

Posted: Sun Jul 12, 2020 4:36 pm
by ivel99
Hi all,

I've been trying for a few days to run RoR and before posting I read the installation guide, the FAQs, browsed the forum but I couldn't identify any solution to my issue. So here I am on the forum as a last resort, hoping some of you may help me out.

I've got Windows 7 and I've downloaded RoR as a torrent and also as a direct download of the whole folder (from a recent troubleshooting post), in both cases keeping my antivirus shut down. I've moved the folder to the deskop, removed read-only and when I launch RoRLauncher.exe or RoRUpdater.exe ... nothing happens. So I've never even landed on the launcher for updates etc. The launcher just doesn't run.

When running either RorLauncher.exe or RoRUpdater.exe, Windows queries me whether to launch as administrator (and I click yes). Ticking 'run as administrator' or any compatibility mode hasn't really led me to any difference -- still nothing happens.

I've checked and under task manager there is no war-related process lingering. It's unclear whether one gets created at all (if it does - it disappears very quickly and wihtout topping the cpu consumption list). It's as if the program never starts. Since the launcher doens't give an error I can't find any meaningful log under event viewer. (just as comparison, I've tried running war.exe, which, as expected, generates an error that is correctly logged in event viewer).

Following the FAQs I've checked .net 3.5 and it's already active. I've tried deactivating and reactivating it, still nothing.

I've tried installing directx9.0c, didn't help (I had more recent ones)

I've tried whitelisting the whole folder in my antivirus, didn't help.

Windows defender is off, so that shouldn't be the problem.

Added an exception to Windows firewall, didn't affect my problem.

I've tried downloading the torrent again a couple of times, that didn't help.

So, I'm out of ideas. I'd really appreciate any suggestions for solving the problem or for helping me troubleshoot it (maybe force windows to generate a log? I wouldn't know how to do that).

Thanks a lot in advance for any help!

Re: Launcher not launching - tried everything, out of ideas

Posted: Mon Jul 13, 2020 1:04 am
by Cdosrun
Just to throw it out there -

I had issues with my first patch after installing the game, The launcher would just 'vanish'. Whitelisted the files and folder,read only, all that fun stuff.

After asking around, posted here, posted on discord someone said 'Vanishing launcher sounds like an antivirus issue'.

I turned it ALL off, no third party antivirus, No windows defender, everything off!

This allowed me to patch and continue playing.

Even now with AV on the launcher will vanish after 10-15 seconds of being open. I have to disable AV COMPLETELY to patch.

Re: Launcher not launching - tried everything, out of ideas

Posted: Thu Jul 16, 2020 9:56 pm
by ivel99
Interesting, thank you.

I've tried your suggestion -- re-downloading it with AV uninstalled, defender off, etc, but still nothing. The file does not vanish -- it just doesn't do anything. The file stays there and as far as I can see, it's not quarantined anywhere.

Anybody else with some other ideas?