Page 1 of 1

3d models issue

Posted: Tue Jun 30, 2020 10:40 pm
by elarvil
Anyone got the same problem?

a couple of weeks ago, i got problems with models on horses: they appear standing on horses, with the arms wide open, like a cross. The basic 3d model position, I guess.

I tryied to repair the game, with no luck.
I tryied to reinstall the game from the previous install package used for the 1st installation (it worked for months), but got the same bug.

I tryied to delete the whole folder, downloaded again the game, reinstalled the DX component.
Well, now i can see only the character's weapons, and the armor parts on the floor. Reminds me Saint Seya's armors XD

Is this a known bug?
thank you

[APUryzen 2400g, driver updated at the last version, i usually play @70/90 fps, 50/60 during keep's zerg ]

Re: 3d models issue

Posted: Wed Jul 01, 2020 4:13 pm
by Extol
Just logged in after a few weeks and have the exact same issue. In game I only see a floating weapon.
Any fixes?

Re: 3d models issue

Posted: Thu Jul 02, 2020 1:41 pm
by elarvil
Hi, i fixed it, but I'm not sure about WHAT exactly has done the trick :D

- I moved warhammer folder on desktop
- I installed the DirectX linked in the "Join Us" page AND the package included in the installation kit. both. (lol)
- I checked that all files and folders was NOT read-only
- I set to both rorlauncher and ROR updater"(run as administrator"
- I ran rorupdater
- I ran rorlauncher
now it works.

I also full removed the AMD-Catalyst drivers (with Revo uninstaller), then I let windows install the basic drivers.

A friend of mine just told me that he got the same bug (he logged 3 days ago with no problems :D)

Re: 3d models issue

Posted: Thu Jul 09, 2020 5:48 pm
by Valarion
If your graphics are bugged and your character is invisible, right mouse click on the war-64.exe -- select properties -- and rerun this program as an admin

The main thread and full solution is here: ... =4&t=39031