Recent Topics

Ads

Really bad performance, need some help!

Problems installing or downloading the game? Check the Install Guide first.

Moderators: Developer, Management, Web Developer

Forum rules
READ THE INSTALL GUIDE BEFORE YOU POST IN THIS SUBFORUM.

The stickies exist to handle common queries. Save our time and yours by reading them first.

Thank you.
oneangryflamer
Posts: 9

Really bad performance, need some help!

Post#1 » Mon May 18, 2020 11:32 am

Hi guys,

i have the problem that oRvR/sieges are unplayable for me and i don't know what else i can do to improve the performance.
Sometimes I have only 8-10fps although I set all video settings to low and start the game with the 64bit exe.

My hardware looks like the following:

GTX 1080
Ryzen 2600x
1440p Resolution

When I look at the load on my CPU and GPu via Afterburner I see that they are bored to death.

Actually there should be more to it with the hardware or is the bad performance with oRvR/sieges due to the server structure?

ImageImage

Ads
User avatar
xpander
Posts: 173
Contact:

Re: Really bad performance, need some help!

Post#2 » Mon May 18, 2020 11:51 am

GPU doesn't even matter for this game. you can turn most of the settings on if you like those.
just keep spell effects self or party only animations balanced and view distance at medium. rest can be maxed.

now if you have so bad framerates i would try without addons first. Make sure you delete your user folder also where all the addon cache and confs are.

delete cache folder from warhammer folder if you havent done it long time.

restrict cpu cores for the game.. set te affinity to 4 cores with no SMT for example.

User avatar
Wdova
Posts: 546
Contact:

Re: Really bad performance, need some help!

Post#3 » Mon May 18, 2020 11:52 am

9fps is bit too low, I got about 20fps. I have the same with my Ryzen 5 3600(usage 7-13%, max I saw was 20% I think) and GPU RX 5600 xt running at 700-800mhz clock speed insted of 1750mhz with about the same usage as CPU. I think nowadays PCs are bored to death with WAR and refuse to run at theyr full speeds. Its not only You, but majority of playerbase.
Last edited by Wdova on Mon May 18, 2020 12:08 pm, edited 1 time in total.
Pigbutcher - Choppa RR80+

emiliorv
Posts: 519

Re: Really bad performance, need some help!

Post#4 » Mon May 18, 2020 11:59 am

Spoiler:
oneangryflamer wrote:
Mon May 18, 2020 11:32 am
Hi guys,

i have the problem that oRvR/sieges are unplayable for me and i don't know what else i can do to improve the performance.
Sometimes I have only 8-10fps although I set all video settings to low and start the game with the 64bit exe.

My hardware looks like the following:

GTX 1080
Ryzen 2600x
1440p Resolution

When I look at the load on my CPU and GPu via Afterburner I see that they are bored to death.

Actually there should be more to it with the hardware or is the bad performance with oRvR/sieges due to the server structure?

ImageImage
This happens you always?? when you target kepp boss the fps drop is noticeable...really dunno why, i assume is for massive debuffs/dots/etc that target have applied...

Draugris
Posts: 296

Re: Really bad performance, need some help!

Post#5 » Mon May 18, 2020 12:22 pm

What kind of Addons do you have active ? I had severe fps issues which went away immediately after disabling Buffhead and Amethyst.
Live: Carroburg -> Santorro (WH), The first Guard (TfG)

Akalukz
Posts: 824

Re: Really bad performance, need some help!

Post#6 » Mon May 18, 2020 12:34 pm

I found it to be a windows issue. Once I started using Razor Cortex game boost (which basically disables a lot of windows crap) my FPS increased significantly. Also take a look at the new addon for performance increase. Was averaging 12-20 FPS now easily 40+ in RvR.
-= Agony =-

User avatar
Phantasm
Posts: 168

Re: Really bad performance, need some help!

Post#7 » Mon May 18, 2020 4:26 pm

Trust me, everyone have same issue with low fps and stutters in keep sieges, expecially in lord room with 200+ guys around you. Even with said above Performance addon you would still get below 20fps at lord kill.
Few thinks that help fight this:
- Clear "Cache" folder regularly
- Disable unnessary addons while you RvRing (like MiracleGrowRemix)
- If you can disable kills in zone (Enemy settings)
- Set effects to self or party

Borek
Posts: 46

Re: Really bad performance, need some help!

Post#8 » Mon May 18, 2020 4:33 pm

yeah, sadly it's killed my will to play, i tried everything and it's still a slideshow at every keep if i join a WB. Just not realistic to expect a full reboot, cache deletion and running the repair feature every 30 mins just to stop the game playing like poop..

Based on the active player numbers over the last few weeks dropping so much i suspect many many others are feeling the same as me.

Ads

Who is online

Users browsing this forum: No registered users and 21 guests