Recent Topics

Ads

Win 10 1803 "April Update" - Black, No Graphics, Only buttons

Problems installing or downloading the game? Check the Install Guide first.

Moderators: Developer, Management, Web Developer

Forum rules
READ THE INSTALL GUIDE BEFORE YOU POST IN THIS SUBFORUM.

The stickies exist to handle common queries. Save our time and yours by reading them first.

Thank you.
ktomais
Posts: 35

Win 10 1803 "April Update" - Black, No Graphics, Only buttons

Post#1 » Thu May 03, 2018 10:22 pm

Hey folks,

Win 10 updated me to the latest version and I don't have the option to rollback to 1709. I have an ISO for it, but that means basically a format since I will lose all files and apps from the PC. Update: Format performed.

The issue is that even with a fresh download of Warhammer I get black where graphics are supposed to be and I can see only the interface buttons. Also, when I press play and it starts loading Nordland (I've used /stuck) when it looks like just about to get in the game it crashes to the desktop.

Has anyone faced a similar issue before, or this issue while running on 1803?

(Update 25/05/18) SOLUTION: Create a second Windows account, upgrade it to Administrator. Remove the account that is unable to play WAR by the Accounts & Users control panel. Delete the removed users folder, inside Local Disk (C:) > Users. Create a new STANDARD account (local/online) with your default user. Now it should work. After confirming WAR functionality you can upgrade this account to Admin again. !!! Make sure that any documents you wish to save from your original user profile get transferred to the new one !!!


Unfortunately the above solution stopped working shortly after and recent similar attempts do not work.

Things already attempted (updated 20/05/18)

- Refreshing Windows installation
- Fresh game installation
- Downloading torrent without AV to avoid any "cleaning" while downloading
- DX9.0c
- Placing the d3dx9_34.dll inside the game's directory
- Turning-on the Windows features for legacy .NET and DirectPlay
- Removing read-only restrictions
- Removal of GPU drivers with DDU and also applying the new NVIDIA hotfix (drivers 397.55)
- Rolling back NVIDIA drivers (391.35)
- Running in every possible compatibility mode
- Copy-pasting a healthy installation of the game
- Format and install 1709
- Format again and install 1803 fresh (current)
- Underclock and voltage control with MSI afterburner
- Trying with no AV and firewall
- Running as admin
- Reinstalling all packages of VC++ and .NET with any SP if applicable

I'll appreciate any advice you can provide.

What the issue looks like: https://ibb.co/db12uS
What my RoR folder looks like: https://ibb.co/k8yAg7 fresh installation from latest torrent
Last edited by ktomais on Thu Apr 30, 2020 4:36 pm, edited 21 times in total.

Ads
User avatar
Secrets
Developer
Posts: 204

Re: Win 10 1803 "April Update" - Black, No Graphics, Only buttons

Post#2 » Thu May 03, 2018 11:22 pm

The Nvidia drivers might actually be the issue. Download the ones prior to April; the new ones have some BSODish bugs.

ktomais
Posts: 35

Re: Win 10 1803 "April Update" - Black, No Graphics, Only buttons

Post#3 » Thu May 03, 2018 11:35 pm

Thanks for the input. Do you remember the version? Edit: If you mean 391.35 (Mar 27) I've already tried them.

User avatar
Aaz
Posts: 2

Re: Win 10 1803 "April Update" - Black, No Graphics, Only buttons

Post#4 » Fri May 04, 2018 9:30 am

I also had problems with Win 10 1803, blue screen + PC reboot.
During a crash, I saw a window Nvidia Share that created the error, suddenly, I uninstalled Nvidia Experience, and since everything is fine ..

i use a version 397.31

User avatar
Mystriss
Posts: 262
Contact:

Re: Win 10 1803 "April Update" - Black, No Graphics, Only buttons

Post#5 » Fri May 04, 2018 1:07 pm

Two things you could try:

1. Delete your cache folder.

2. Rename the Warhammer > User folder to user_old and see if it goes (Wipes out a bunch of UI customization, but it's recoverable so long as you save a copy of the folder, just a matter of figuring out which sub-folder in there is causing the problem.)


As a semi-related note, a recent windows 10 update took out my AMD GPU fan controller functionality, causing my system to shut down automatically when the GPUs hit 73C. Windows doesn't play well with others sometimes >.< [Can use GPU-Z to monitor and log your GPU temps, then MSI Afterburner can be used to create a manual fan profile to resolve.]
Image

ktomais
Posts: 35

Re: Win 10 1803 "April Update" - Black, No Graphics, Only buttons

Post#6 » Fri May 04, 2018 2:49 pm

Thanks for your suggestions. I will try them tonight and let you know. Apparently a cumulative is also on the way, to fix several things the update broke.

Edit: I attempted your solutions but with no luck unfortunately.

Edit 1: Do you think Game Mode might have something to do with it? In 1803 there isn't a setting to turn it off. Is there a way using regedit?

ktomais
Posts: 35

Re: Win 10 1803 "April Update" - Black, No Graphics, Only buttons

Post#7 » Sat May 05, 2018 9:29 am

I managed to get in completely randomly, faced with this: https://ibb.co/cf7oM7. The interface is sort of transparent. Reloading UI crashed it into unbootable again.

User avatar
Mystriss
Posts: 262
Contact:

Re: Win 10 1803 "April Update" - Black, No Graphics, Only buttons

Post#8 » Sun May 06, 2018 11:06 pm

Game mode (assuming you mean win 10s) shouldn't effect it like that - all it does, as I understand it, is prioritize the game (which you can actually do yourself through task manager) Couldn't hurt to try turning it off though.

Looking at the SS you posted, I really wanna say that an addon has borked everything up. Try renaming the Interface folder to Interface_old and see if that sorts it.

If not then you might try reinstalling directx.
Image

Ads
ktomais
Posts: 35

Re: Win 10 1803 "April Update" - Black, No Graphics, Only buttons

Post#9 » Tue May 08, 2018 7:55 am

The image you see is from a fresh installation of Warhammer.

Additionally, I've basically formated my PC, twice. Put 1803 again, didn't work. Then I put 1709, didn't work.

Also webroot identifies the RoR launcher as a Trojan. I've allowed it, but it didn't do it before, with my old installation.

In the 2nd format I installed Warhammer with no AV to make sure nothing was blocked. Didn't work.

Now on third and final format. Can't figure out what happened. But if it doesn't work now that's it as far as I'm concerned.

DX9 has been reinstalled. Do you mean another version?

User avatar
saupreusse
Former Staff
Posts: 2064

Re: Win 10 1803 "April Update" - Black, No Graphics, Only buttons

Post#10 » Fri May 11, 2018 11:37 pm

Absolutely no idea, sorry. When you tried to run it without an av software, did you maje sure it wasnt blocked by windows defender or the firewall? We have some troubles with our launchers certificate atm which might cause trouble with windows.

Who is online

Users browsing this forum: No registered users and 8 guests

cron