Search found 8 matches

>
by mybulldozer
Tue Oct 22, 2019 2:50 am
Forum: Suggestions & Feedback
Topic: FEEDBACK: AOE cap
Replies: 72
Views: 10846

Re: FEEDBACK: AOE cap

Played with change with Mara(aoe), Magus, SH. Pets died almost instantly which nerfed pet classes. ST classes are being punished from said change as they are frowned on in organized wbs. From what I observed there was more blobbing in the zones which is not fun. Being hit by so much aoe is not fun. ...
by mybulldozer
Thu Oct 03, 2019 3:06 am
Forum: Events
Topic: Halloween
Replies: 2
Views: 1179

Halloween

To the staff, ty for all the time and work you put into this project. Any plans for a Halloween event this year? Also, any plans for new content by the end of 2019? Thanks for your time.
by mybulldozer
Thu Sep 26, 2019 12:48 am
Forum: General Discussion
Topic: [Official Poll] Pug Scenario
Replies: 379
Views: 86649

Re: [Official Poll] Pug Scenario

Any chance for a new pug sc? We have had Doomfist since Aug 10th.
by mybulldozer
Fri Mar 29, 2019 8:47 pm
Forum: General Discussion
Topic: Thickmuck Keep
Replies: 0
Views: 205

Thickmuck Keep

Hey, shout out to devs for awesome work. Thickmuck Keep in Badlands has both posterns on order wc side. All other keeps have outer posterns on the opposite sides of said keeps. Would devs be able to put an outer postern facing destro wc for Thickmuck keep?
by mybulldozer
Mon Nov 26, 2018 11:15 pm
Forum: Technical support
Topic: Launcher error after last update
Replies: 10
Views: 815

Re: Launcher error after last update

I am getting the same error. Running RoRLauncher.exe every time and every time connect button not available, instead update is the only thing to click(it's red before being clicked). It then runs an update and when finished the above "an error occured..." message pops up.
by mybulldozer
Mon Nov 26, 2018 4:27 pm
Forum: Technical support
Topic: game
Replies: 10
Views: 676

Re: game

Hello again, I am not able to connect to this fine game. Instead of the "connect" there is in red "update". When I click the update button it does "an update" to 100% then a few seconds later I receive this message "an error occured..." The webserver is green and login server is yellow. Could someon...
by mybulldozer
Sun Nov 25, 2018 6:05 pm
Forum: Technical support
Topic: game
Replies: 10
Views: 676

Re: game

In the login screen it says I have to do an update (which is in red). I have done this 90 times today w/no success. Is this happening to everyone?
by mybulldozer
Sat Jun 17, 2017 8:50 pm
Forum: Game support
Topic: Not able to connect
Replies: 2
Views: 426

Not able to connect

Hello, for the past 20 hours from the launcher I click on the connect button and nothing happens. There are no errors. Is this a launcher problem? Any help will be appreciated.